如何降级JRE版本

阅读用时 ~1 分钟

我们公司的某软件的管理界面用到Java Applet,并且还要求JRE版本不能高于1.6,当前最新的JRE版本是1.8.0.40,而OSX是不支持安装低版本JRE的,此问题的解决办法如下:

安装JDK6

下载并安装:Java for OS X 2014-001

打开『终端』,执行如下命令:

sudo mkdir -p /Library/Internet\ Plug-Ins/disabled 
sudo mv /Library/Internet\ Plug-Ins/JavaAppletPlugin.plugin /Library/Internet\ Plug-Ins/disabled
sudo ln -sf /System/Library/Java/Support/Deploy.bundle/Contents/Resources/JavaPlugin2_NPAPI.plugin /Library/Internet\ Plug-Ins/JavaAppletPlugin.plugin
sudo ln -sf /System/Library/Frameworks/JavaVM.framework/Commands/javaws /usr/bin/javaws

测试

重新启动浏览器,访问:Verify Java Version

恢复

如果需要恢复到原来的JRE版本,重新安装下JRE就好了。

如何拼接多个图片到一个大图片

我想把几张图片拼成一个大图片,实现方式如下:安装 imagemagick{% highlight bash %}brew install imagemagick{% endhighlight %}拼接图片,例如:将1.png, 2.png, 3.png并成me.png,命令...… 继续阅读

如何阻止iOS系统升级

发布于 November 05, 2017